(FIX) Sound Problem with XTRONS Mercedes Benz Retrofit Screen

Technical Advices for Specific Questions / Functions

Moderator: Lukeeeuk

User avatar
xtrons
Site Admin
Posts: 61
Joined: Fri Dec 16, 2016 9:09 am

(FIX) Sound Problem with XTRONS Mercedes Benz Retrofit Screen

Postby xtrons » Fri Sep 10, 2021 11:04 am

Problem analysis is on identifying cause:
The sound signal will travel through audio cable to the factory radio/CD changer in Mercedes Benz.
This is the basic connection of the XTRONS screen:
No.5: AUDIO IN
No.6: AUDIO OUT
MB-Q-WIRING.png
MB-Q-WIRING.png (253.3 KiB) Viewed 3623 times


Sometimes, getting sound for the XTRONS screen with your factory CD changer/radio is a pain. How to connect it to your car depends on what CAMAND system you have, and you might have different audio gateway or protocol in the factory audio cable, which fails to transmit the sound signal between the factory CD changer and the XTRONS screen.

To solve this problem, you need to figure out which component is defective by bypassing the different components until you find the problem.
The solutions depend on the equipment level and functions of your COMAND system.
There are 3 scenarios:

NTG 4.0, NTG 4.5, NTG 4.7 with AUX:
If there is an AUX In port from your car, please confirm if the AUX has been activated.
How to activate AUX ? (NTG 4.5, NTG4.7, NTG 4.0 )
Please refer to this video:


The 2nd step is to check the AUDIO cable. Firstly, please disconnect the plugs of AUDIO IN and AUDIO OUT
Secondly, use the Audio Cable to connect the AUDIO OUT and the AUX IN shown as below:
NTG  AUX.png
NTG AUX.png (187.16 KiB) Viewed 3623 times


NTG4.5,NTG4.7 with AMI port.

For some MB models, they come with the AMI media interface port that is usually located in your Mercedes-Benz glove box or under the armrest.
If your COMAND is NTG4.5,NTG4.7 with AMI port, Firstly, please disconnect the plugs of AUDIO IN and AUDIO OUT as shown in the first scenario above.
Secondly, use the Audio Cable to connect the AUDIO OUT and the AUX IN shown as below:
NTG 4.5 WITH AMI.png
NTG 4.5 WITH AMI.png (886.37 KiB) Viewed 3623 times


NTG5 with two USB ports.

If your car has two type C USB ports, depending on the vehicle's equipment.
Firstly, you also need to disconnect the plugs of AUDIO IN and AUDIO OUT as shown in the first scenario above.
Secondly, you need to pay attention to the order in which the xtrons audio box is connected
If the XTRONS USB box connects to the USB1 port, please switch to the USB1 mode on the XTRONS screen., similarly, USB2 port matches along with USB2 mode, otherwise, you won’t get sound for the XTRONS screen.

Test the Audio out

If the sound still doesn’t work after you have checked the solutions above, then try the next testing. The only testing that you can really perform is to make sure the AUX is in working condition. please disconnect the AUDIO IN and AUDIO OUT, check and test if the audio out on XTRONS screen is working:

AUX TEST 1.png
AUX TEST 1.png (46.42 KiB) Viewed 3623 times


A simple reference would be connecting one pair of wired headphones with a 3.5mm jack and determining if there is any sound coming from them.
If you hear the sound from your headphones, then the XTRONS screen is not the source of any problems you have, it is advised to check original audio input, including AUX, AMI, USB, USB Box.
If the sound is not clear, or you hear nothing, please contact XTRONS customer service for a replacement unit.

If audio input from your car works, it is advised to change the audio cable/AMI cable/USB box.
If audio input from your car does not work, your AUX, AMI, USB might be faulty and then you can purchase the FM02 to get sound, https://XTRONS.co.uk/wireless-fm-transm ... apter-fm02.

Return to “Technical Advice”

Who is online

Users browsing this forum: Google [Bot] and 2 guests